Is Trackur Compatible with Internet Explorer 8 or Older?

Trackur uses the latest HTML5 and CSS3 web standards.

As a result, users will find that they are not able to use Trackur's latest dashboard with IE8 or older, so we encourage you to upgrade to IE9 or IE10.

Have more questions? Submit a request

Comments

Powered by Zendesk